Technorati Rank WordPress Eklentisi Sürüm 2 Çıktı!

İlk Technorati Rank Eklentisinin hemen ardından, çıktı içeriğini bunu yapmak için yeniden tasarladım CSS tahrikli (aşağıda bir ekran görüntüsü verilmiştir, sitemin kenar çubuğundaki ile etkileşim kurabilirsiniz):

Technorati Rank WordPress Eklentisi Sürüm 2

Bunu üretmek biraz daha zordu ama çıktı çok daha güzel. İlk önce öğrendiklerimi kullandım bit kutusu Illustrator'daki görüntü üzerinde çıkış düğmelerinin her birini yapmak için.

Bir sonraki adım, bir kişiyi gerçekten oluşturmak için stilleri kullanmaktı. resim haritası aslında olması dışında harita yok! Aslında oldukça havalı. Genel div arka planını ayarlayabilir ve ardından mutlak konumlandırma ve CSS kullanarak "sıcak noktaların" her birini oluşturabilirsiniz. Çıktı CSS'sini görüntüleyin.

Technorati'nin yenisine de bir bağlantı ekledim WTF sayfası ve sitenin RSS adresi. Umarım beğenmişsindir! İlk versiyondan çok büyük bir gelişme olduğunu düşünüyorum! Bir i Eklentiyi tanıtan sağ alttaki bağlantı.

Mevcut Technorati Rank WordPress Eklentisi Sürüm 2.0.4

23 Yorumlar

  1. 1
  2. 3

    Sizin talimatlarınızı "harf" e göre en yenisini ve en büyüğünü yüklemeye çalıştım 🙂

    ama şu hatayı aldım

    Önemli hata: Varolmayan sınıf: simplexmlelement in /home/winex4/public_html/wp-content/plugins/technorati-rank/technorati-rank.php, satır 64

    baska öneri?

    • 4
      • 5

        bu bana önce kontrol etmeyi öğretecek .. görünüşe göre Lunarpages PHP 4.4.4 çalıştırıyor

        Sanırım diğer sürüme göz atmam ya da zorlanıp 5.0'a yükseltip yükseltmediklerini görmem gerekecek

        • 6

          Umarım yaparlar! Ama aynı zamanda ev sahibinizin de yükselmesini umuyorum. PHP5 gerçekten çok daha iyi performans iyileştirmeleri ve API'leri tüketmek için daha iyi araçlar getiriyor. Jumpline'ı kullanıyorum, ana sayfamdaki sponsor listemde bir bağlantı göreceksiniz. Ayrıca Dotster'ın en yeni ve en iyilerle bazı iyi VDS barındırma hizmetlerine sahip olduğuna inanıyorum.

      • 7

        Doug
        Bendede aynı sorun var
        Ana makinemi aradım ve sunucumun PHP 4 ve PHP 5 olduğunu söylediler, ancak PHP 5 kullanarak bir dosya çalıştırmak istersem, komut dosyasının .php5 dosya uzantısına sahip olması gerekir.

        Yani… Dosya uzantılarını değiştirdim ve wordpress eklentilerinden kayboldu.

        Herhangi bir fikir?

  3. 10

    Müthiş Eklenti, Mükemmel stil! Teşekkürler Doug, harika iş. İlkini hiç bilmiyordum, ama bu benim yan çubuğuma hemen girecek.

    Illustrator ipuçlarımın düğmelerinizi oluşturmanıza yardımcı olduğunu görmek GERÇEKTEN ödüllendirici !!!!!

    Tekrar teşekkürler,

    ~ BittBox

    • 11

      Teşekkürler BittBox! Tarz konusunda iyi bir gözüm olduğunu düşünüyorum, ama çoğu zaman onu asla doğru yapamıyorum. Farkı yaratan, örneklerinizi gerçekten indirip parçalara ayırabilmek. Şimdi bu fikirleri gerçekten hayata geçirebiliyorum. 🙂

      Bir sonraki blogumun başlığı ve arka planıyla ilgili bazı düşüncelerle oynuyorum.

  4. 12

    Pekala Doug, sürüm 2 eklentisi benden nefret ediyor gibi görünüyor. Hata mesajları alıyorum:

    Warning: fopen(/technorati-rank.html) [function.fopen]: failed to open stream: Permission denied in /..../wp-content/plugins/technorati-rank/technorati-rank.php on line 121
    Warning: fwrite(): supplied argument is not a valid stream resource in /..../wp-content/plugins/technorati-rank/technorati-rank.php on line 122
    Warning: fclose(): supplied argument is not a valid stream resource in /..../wp-content/plugins/technorati-rank/technorati-rank.php on line 123

    Hata mesajlarına rağmen Technorati rankımı da gösteriyor (~ 26.5k: D). PHP hakkında neden o dosya için ağladığını anlayacak kadar bilgili değilim.
    Yeterince ilginç bir şekilde, sunucumuzda SuPHP kullanıyoruz, böylece her şey bizim gibi çalışır (böylece chmod gereksinimleri artık herkes tarafından yazılabilir dosyalar gerektirmez ve örneğin chmod çok yüksekse php betikleri çalıştırılmaz).

    Bu alt alan için tüm php'ler php5 olarak çalışır.

    Herhangi bir fikir?

    • 13

      Xial wp-content / cache dizininiz var mı? WP-Cache ile aynı önbellek dizinini kullanmanın iyi bir fikir olacağını düşündüm. Geriye dönüp baktığımda, belki de iyi bir fikir değildi! Bu satır kesinlikle önbellek dosyasına yazmak içindir.

      • 14

        Kesinlikle seviyorum Doug. Bir süredir WP-Cache çalıştırıyorum. 🙂

        Gerekli dizine sahip olduğum için neden bundan şikayet edeceğini de biraz merak ettim, ama sanırım bu tamamen başka bir şey.

      • 15

        Eklenecek ilginç bilgiler:

        $ pwd
        /..../wp-content/cache
        $ ls -l tech*
        -rw-r--r-- 1 meeeeeeee meeeeeeee 1.1K Mar 12 11:47 technorati-rank.html

        Hala hataları döndürür.

    • 16

      Sadece aynı hatayı yapmak istiyorum. Site php5'i çalıştırır ve düğme görüntülenir.
      121-123. Satırları yorumlamayı denedim ve fiş iyi çalışıyor. Canlı yayınlayabilir miyim, yoksa bu çizgilerin olmaması uzun vadede sorun yaratır mı?

  5. 17

    Yukarıdaki ile aynı hataları alıyorum, ayrıca bunun benim önbelleğim olduğunu düşündüm ama bir tane var ve ayrıca yazma haklarının doğru olduğundan emin oldum.
    Yan çubukta eklenti (sıralı) gösterecek, ancak üstündeki bu hatalarla.

    • 18

      Merhaba Richard,

      PHP 5+ sürümüne sahip olduğunuzu ve CURL'nin etkinleştirildiğini kontrol edebilir misiniz? Bunu, sitenizde bir sayfa oluşturarak yapabilirsiniz. <?php phpinfo(); ?> bir sayfada. Sonra o sayfayı açın. Sayfanın üstünde sizin PHP sürümünüz olacak ve etkin olduğundan emin olmak için CURL için bir arama yapabilirsiniz.

      Teşekkürler!
      Doug

      • 19

        Doug, PHP sürümümü iki kez kontrol ettim.
        PHP5 çalıştırıyorum ve cURL derlendi (ana bilgisayarıma yaptığım her zamanki üç istek, şeylerin PHP'ye derlenmesi için).

        Diğer her şey iyi çalışıyor, ancak PHP'ye derlenmiş cURL sürümü olmadığı sürece bu eklentinin neden boğulduğundan tam olarak emin değilim (7.15.4'teyiz ve en son sürüm 7.16.1 olarak görünüyor). Bununla birlikte, eğer yardım edebilirsem, sunucumu sadece bunun için php5'i tekrar derlemesi için rahatsız etmek istemiyorum. <: 3

        • 20

          Bu hafta sonu daha derinlemesine bakacağım. Birkaç sitede sorunsuz çalışıyor - yani 3 şeyden biri: 1. Önbellek, 2. cURL veya 3. PHP Sürümü.

          XML'i çekmek ve ayrıştırmak için eski PHP 4 işlevselliğini kullanabilirim, ancak bu onu biraz yavaşlatabilir - bu hafta sonu test edeceğim. Tüm girdilere minnettarım. "Houston Bir problemimiz var!".

  6. 21
  7. 22
  8. 23

    Önbellek dosyasından yazarken veya okurken hatalar olduğuna dair epeyce istek aldım. Aslında önbellek dosyasını kök dizine ittiğim ve çektiğim bir sorunu belirledim. 2.0.4 sürümünü, eklentinin dizinindeki bir önbellek alt dizinine yazması için değiştirdim.

    Lütfen nasıl çalıştığını bana bildirin! (Hala SimpleXML ve cURL'ye ihtiyaç var!)

Ne düşünüyorsunuz?

Bu site spam'i azaltmak için Akismet'i kullanıyor. Yorum verilerinizin nasıl işlendiğini öğrenin.